GenTime

აღწერა

GenTime

This plugin shows site administrators the time in seconds of how fast the page loaded in the WordPress admin bar.

That’s it, pretty simple!

დაყენება

  1. Install GenTime either via the WordPress.org plugin directory or upload the files to your server.
  2. Either Network Activate this plugin or activate it on a single site.
  3. That’s it!

ფილტრები

Changes the minimum role for which the GenTime is shown:

add_filter( 'gentime_minimum_role', 'my_gentime_minimum_role' );
function my_gentime_minimum_role( $default = 'install_plugins' ) {

    // See https://codex.wordpress.org/Roles_and_Capabilities for a list of role names
    $role = 'edit_pages';

    return $role;
}

Changes the number of decimals to output:

add_filter( 'gentime_decimals', 'my_gentime_decimals' );
function my_gentime_decimals( $default = 3 ) {
    return 4;
}

მიმოხილვები

23.07.2021
Doesn't bog down the system and works as expected! Better than any other timing plugin I've used.
03.09.2016 1 reply
I love Sybre's plugins. This one is soo simple, soo useful, no idea how this feature is not included in most seo or all-purpose plugins. Highly recommended for people dedicated to speed up their site!
3 რევიუს წაკითხვა

მონაწილეები & დეველოპერები

“GenTime” ღია პროგრამული უზრუნველყოფაა. შემდეგმა ადამიანებმა წვილი შეიტანეს მის განვითარებაში.

მონაწილეები

“GenTime” ითარგმნა 2 ენაზე. გმადლობთ თარჯიმნებო თქვენი წვლილისათვის.

გადათარგმნეთ GenTime თქვენს ენაზე.

დაინტერესებული ხართ დეველოპმენტით?

დაათვალიერეთ კოდი, შეამოწმეთ SVN რეპო, ან გამოიწერეთ შექმნის ჟურნალი : RSS.

ცვლილებები

1.1.0

  • Added: Now uses WordPress 5.8’s more accurate function, when available, timer_float().
  • Updated: Now uses HTML5 for the styles output.
  • Other: Refactored the plugin to support PHP 5.6 or later, from 5.2 or later.
  • Other: Cleaned up code.

1.0.4

  • Fixed: This plugin is now converted to UNIX line feed.
  • Improved: Early sanitation of translation strings.
  • Updated: POT file.
  • Confirmed: WordPress 4.6 support.
  • Other: The plugin license has been upgraded to GPLv3.
  • Other: Cleaned up code.

1.0.3

  • Fixed: The cache now works as intended.
  • Fixed/Improved: Erroneous order of function checking. Which actually had no impact.
  • Other: gentime_minimum_role filter now converts input to string.

1.0.2

  • Added: POT translation file.
  • Improved: Slightly improved performance (every Herz counts) by adding PHP runtime static cache earlier.
  • Confirmed: WordPress 4.5+ compatibility.
  • Cleaned up code.

1.0.1

  • Changed: Minimum capability from edit_plugins to install_plugins so that the generation time is still shown when the Editor has been disabled.
  • Added: PHP Staticvar caching for capability.
  • Confirmed: 4.4.0+ support.
  • Cleaned up PHP.

1.0.0

  • Initial Release