ეს პლაგინი არ დატესტილა WordPress-ის 3 ძირითად ვერსიაზე. როგორც ჩანს, ის უკვე აღარ არის მხარდაჭერილი და შესაძლოა არ იყოს თავსებადი WordPress-ის მიმდინარე ვერსიასთან.

WP Composer Sync

აღწერა

WP Composer Sync is a WordPress plugin that keeps a WordPress installation’s composer.json synchronised with the plugins installed.

Usage

Once installed the plugin should be largely set and forget, however there a couple of gotchas.

1) Commercial plugins that are not available from the WordPress.org plugins repository will still be added you will need to manually modify the repository (eg. wpackagist, wp-premium or using a custom installer or repository) or add your custom plugins first. WP Composer Sync will then honor these repositories and keep them synchronised as well.
2) When composer installs a package, it completely empties the target directory before installing the new files. As such, the WordPress path should be designated for WordPress core files only, as anything else (e.g. plugins, themes, and wp-config.php) will be wiped away on install or update. It is recommended that you keep your wp-config.php file in the parent directory of the WordPress path (WordPress can find it there automatically) and replace the wp-content directory with a symlink to your real wp-content folder. See link for more details.
3) Compposer require versioning wildcards (eg. *, 1.*, etc) will not be honoured (as WordPress does not adhere to this). They will be replaced by the exact version number in use by WordPress.

About

Why?

Composer is a great way to manage WordPress and its plugins. However in real life it runs the risk of becoming outdated with the actual contents of the website when admin users are installing plugins via wp-admin or S/FTP.

How?

Using WordPress’s “plugins_loaded” action and link, this plugin will check your composer.json file for any outdated or unfound plugins and will automatically add them to the require section.

Roadmap

The plugin is production ready however there are some additional functions and features which will be added in the future:

1) Add ability to select bewteen https://github.com/balbuf/composer-wp and wpackagist
2) Currently only syncs plugin and wordpress core, add ability to sync themes
3) Research some ways to monitor plugin-uploads and changes more effectively (eg. link link, link and link or Transients link link or link)

დაყენება

Regardsless of installation method the machine where you are running WordPress requires Subversion to be installed to allow access to WordPress’s SVN repositories. On *NIX based servers you can simply:

`

apt -yq install subversion
`

New WordPress Install

You can use composer to create your new WordPress instance and include WP Composer Sync. In the root of your project folder simply create a composer.json file containing:

`

{
“name”: “The name of your WordPress site”,
“extra”: {
“composer-wp”: {
“repositories”: [],
“vendors”: {},
“installer”: {
“wordpress-path”: “web”
}
}
},
“require”: {
“wordpress/wordpress”: “^4.9.7”,
“wordpress-plugin/wp-composer-sync”: “*”
},
“scripts”: {
“pre-cmd”: [
“composer global require balbuf/composer-wp && composer global update balbuf/composer-wp”
],
“pre-install-cmd”: “@pre-cmd”,
“pre-update-cmd”: “@pre-cmd”
}
}
`

This will install wordpress in a web/ sub-directory (recommended, but you can change the web root by modifying the “wordpress-path”). It will also globally install link.

Existing WordPress Install

If you wish to install WP Composer Sync into an existing (composer managed) WordPress install start by installing link:

`

$ composer global require balbuf/composer-wp
`

Now you need to add WP Composer Sync to your WordPress install either via wp-admin or via composer:

`

$ composer global require wordpress/wp-composer-sync
`

ხდკ

Installation Instructions

Regardsless of installation method the machine where you are running WordPress requires Subversion to be installed to allow access to WordPress’s SVN repositories. On *NIX based servers you can simply:

`

apt -yq install subversion
`

New WordPress Install

You can use composer to create your new WordPress instance and include WP Composer Sync. In the root of your project folder simply create a composer.json file containing:

`

{
“name”: “The name of your WordPress site”,
“extra”: {
“composer-wp”: {
“repositories”: [],
“vendors”: {},
“installer”: {
“wordpress-path”: “web”
}
}
},
“require”: {
“wordpress/wordpress”: “^4.9.7”,
“wordpress-plugin/wp-composer-sync”: “*”
},
“scripts”: {
“pre-cmd”: [
“composer global require balbuf/composer-wp && composer global update balbuf/composer-wp”
],
“pre-install-cmd”: “@pre-cmd”,
“pre-update-cmd”: “@pre-cmd”
}
}
`

This will install wordpress in a web/ sub-directory (recommended, but you can change the web root by modifying the “wordpress-path”). It will also globally install link.

Existing WordPress Install

If you wish to install WP Composer Sync into an existing (composer managed) WordPress install start by installing link:

`

$ composer global require balbuf/composer-wp
`

Now you need to add WP Composer Sync to your WordPress install either via wp-admin or via composer:

`

$ composer global require wordpress/wp-composer-sync
`

მიმოხილვები

There are no reviews for this plugin.

მონაწილეები & დეველოპერები

“WP Composer Sync” ღია პროგრამული უზრუნველყოფაა. შემდეგმა ადამიანებმა წვილი შეიტანეს მის განვითარებაში.

მონაწილეები

გადათარგმნეთ WP Composer Sync თქვენს ენაზე.

დაინტერესებული ხართ დეველოპმენტით?

დაათვალიერეთ კოდი, შეამოწმეთ SVN რეპო, ან გამოიწერეთ შექმნის ჟურნალი : RSS.

ცვლილებები

1.0

  • Initial version